Image loading issues
Incident Report for Chorus
Resolved
The issues impacting images has been resolved. Thank you for your patience while we’ve been working on this.
Posted Mar 30, 2020 - 15:45 EDT
Investigating
We’re currently investigating reports that images are slow to load for some users. We’ll continue sharing updates here as we have them.
Posted Mar 30, 2020 - 15:02 EDT
This incident affected: Chorus sites and Chorus story editor.