This is a test of the Curbed emergency broadcast system
Incident Report for Vox Media
Resolved
We did it
Posted almost 2 years ago. Jan 14, 2016 - 15:38 EST
Investigating
We're working on this now
Posted almost 2 years ago. Jan 14, 2016 - 15:34 EST