Chorus downtime
Incident Report for Vox Media
Resolved
The issue impacting Chorus sites and story editor has been resolved.
Posted Feb 24, 2020 - 10:26 EST
Investigating
We’re currently investigating reports that Chorus sites and story editor are down. We’ll continue to share updates here as we have them.
Posted Feb 24, 2020 - 10:19 EST
This incident affected: Chorus (Chorus sites, Chorus story editor).