Video playback issues
Incident Report for Vox Media
Resolved
According to our video provider, the issues have been addressed and all video playback should be back to normal on the Vox Media network.
Posted Jun 18, 2014 - 10:52 EDT
Identified
We're experiencing video playback issues across all Vox Media properties.
Posted Jun 18, 2014 - 10:10 EDT